Lompat ke konten Lompat ke sidebar Lompat ke footer

Cara memunculkan User Online Hotspot Mikrotik

Cara memunculkan User Online Hotspot Mikrotik 2021 -  Cara ini bisa kamu gunakan untuk memunculkan user yang aktif di halaman login Hotspot Mikrotik kita dengan jumlah pengguna yang aktif (online) saat ini di halaman login Hotspot Mikrotik.

Kamu dapat mengikuti tutorial ini agar bisa memunculkan user online di halaman login Hotspot Mikrotik dan membuat user/pengguna hotspot kita bisa mengetahui akan jumlah pengguna saat ini yang sedang online/aktif pada jaringan hotspot Mikrotik, simak dan ikuti tutorial ini ya.


Edit File HTML

Tahap ini digunakan untuk membuat sebuah file yang akan kita gunakan sebagai media tampilan atau file HTML yang akan memunculkan user online hotspot Mikrotik saat ini.

1. Buatlah file baru dengan ekstensi .js / .html dengan file name sesuai selera, (contoh: user-on.html).

2. Upload user-on.html ke folder atau penyimpanan yang ada di server mikrotik, jangan lupa ingat lokasi dan folder untuk menyimpan (contoh: ../Upload/user-on.html). jika kebingungan cek gambar dibawah ini.

Cara memunculkan User Online Hotspot Mikrotik
Cara menampilkan User Online Hotspot Mikrotik
Note : Untuk cara upload file ke server mikrotik bisa kalian gunakan fitur upload pada winbox atau drag and drop dari folder yang ada di PC kamu ke system file yang ada di mikrotik. opsi lain bisa menggunakan aplikasi pihak ketiga seperti filezilla, winscp, putty dan lainnya juga bisa menggunakan akses ftp file ke mikrotik.



Script User Online Mikrotik Hotspot

1. Tahap ini kita lakukan dimana kita membuat Script yang digunakan sebagai media cetak otomatis atau perintah menghitung total user aktif saat ini pada file user-on.html secara otomatis.

Script Kode


/ip hotspot active
:global klient;
:global gratis;
:set klient ([print from=[/ip hotspot active find login-by=http-chap] count-only])
:set gratis ([print from=[/ip hotspot active find login-by=trial] count-only])
/file set Upload/user-on.html contents= \
"User Aktif = $klient  | User Gratis Trial = $gratis  "
}

2. Silahkan pasang Script di atas ke mikrotik pada system > script > script add new script .

Cara memunculkan User Online Hotspot Mikrotik
system script new mikrotik


3. Di menu New Script, copy dan paste kode script di atas ke form source code, kemudian isi nama sesuai selera kamu (contoh: user-on), jangan lupa klik apply dan ok.

Cara memunculkan User Online Hotspot Mikrotik
system scrip halaman user-on

Note:
 Perlu diingat nama script yang kita buat sebelumnya yakni user-on akan kita gunakan lagi pada system > scheduler di bagian "On Event". jadi harap diingat ya agar tutorial cara memunculkan user online pada halaman login mikrotik bisa sukses.


Menambah Scheduler

Tahap ini kita lakukan agar script yang sebelumnya kita buat berjalan secara otomatis menggunakan scheduler. atau bisa juga dengan waktu dan interval yang telah kita tentukan untuk eksekusi script sebelumnya.

1. Login ke winbox

2. klik system > scheduler > add news scheduler kemudian klik tombol + . Jika kebingungan cek gambar.

Memunnculkan user online di halaman login mikrotik
system schheduler add new mikrotik hotspot

3. Akan tampil jendela baru dengan nama New Schedule, untuk kolom Name, Start Date, Start Time, Interval, dan On Event silahkan isi sesuai dengan script sebelumnya. Untuk name isi sesuai selera. jika kebingungan ikuti gambar dibawah.

Memunnculkan user online di halaman login mikrotik
system scheduler mikrotik 2021


4. Kamu cukup mengisi nama script sebelumnya yakni user-on pada kolom On Event agar script sebelumnya bisa dieksekusi oleh sistem mikrotik, dan juga kamu tidak perlu melakukan copy dan paste script lagi pada tahap ini.

Memunnculkan user online di halaman login mikrotik
system script & scheduler mikrotik login page

5. Langkah terakhir yakni kita akan memasang script syntax yang digunakan untuk memunculkan atau memanggil user online ke halaman hotspot login mikrotik. kamu juga bisa menempatkan script ini secara terpisah seperti pada alogin.html, status.html atau juga bisa kamu pisah untuk memunculkan user online saat ini saje.

Cara memunculkan User Online Hotspot Mikrotik
Tampilan user aktif  di halaman login mikrotik hotspot


Kalian hanya perlu menentukan lokasi/alamat file user-on.html yang sudah ada pada direktori root server mikrotik dengan menggunakan tag pembungkus seperti <object> atau <iframe>. Syntax simpel ini bisa kamu pelajari di W3 School.

jangan lupa untuk struktur direktori/folder seperti ../Upload/user-on.html agar sesuai dengan tahapan sebelumnya.


Cara menggunakan syntax:

Syntax <iframe>

<iframe src="/Upload/user-on.html" width="100" height="21"></iframe>

Syntax <object>

<object src="/Upload/user-on.html" width="100" height="21"></object>

Tahap selanjutnya menambahkan syntax tersebut ke dalam file yang akan kita gunakan untuk memunculkan user online pada template login hotspot sebagai media untuk memunculkan informasi user yang sedang online pada jaringan hotspot kita. disini saya akan sisipkan syntax tersebut kedalam file login.html .

Cara memunnculkan user online di halaman login mikrotik
edit login.html halaman login hotspot mikrotik


Silahkan edit login.html dengan editor kesayangan kamu. untuk saya pribadi saya akan menempatkan script tersebut di <body> agar bisa memunculkan informasi mengenai user yang sedang aktif / login di jaringan hotspot mikrotik kita bisa mengetahui jumlah user online pada saat ini.


Kesimpulan

Cara ini bisa kamu gunakan sebagai cara untuk memunculkan informasi jumlah pengguna yang sedang aktif/login pada jaringan hotspot mikrotik kita secara realtime dengan interval waktu update yang telah kita tentukan sebelumnya di system > scheduler, dengan itu metode untuk memunculkan user online pada halaman login hotspot mikrotik bisa digunakan secara seksama dan juga sukses.


Demikian artikel mengenai cara memunculkan user online hotspot mikrotik 2021 ini. jika ada kendala dan pertanyaan bisa kamu tanyakan di kolom komentar blog ini. Terlebih jika ada kendala dan kekurangan pada bagian scripting.

Terima Kasih Piece and Out.

Posting Komentar untuk "Cara memunculkan User Online Hotspot Mikrotik"