Lompat ke konten Lompat ke sidebar Lompat ke footer

Reboot Otomatis Interface MikroTik

Restart the MikroTik Ethernet Interface automatically


www.dani31.xyz - Pernahkah Kalian mengalami sebuah kejadian dimana status koneksi pada Interface Ethernet MikroTik menunjukkan berjalan normal, Link Ok, Rate 1GB, tetapi ketika pengujian ping hasilnya bahkan Timeout. hal ini biasanya terjadi jika kita memasang banyak sekali konfigurasi didalamnya, 

Contoh kasus : saya disini memasang sebuah konfigurasi untuk koneksi otomatis dengan jarigan wifi.id yang ada di sekitar tempat tinggal saya, dan juga sebuah VPN dari nordvpn MikroTik yang digunakan untuk koneksi game agar lebih stabil. Awalnya masih belum ada kendala tetapi selang beberapa hari kemudian terjadi error yang menyebabkan koneksi di interface wlan (wifi yang terkoneksi dengan wifi id tadi) bengong atau tidak ada traffic yang mengakibatkan internet mati. 

Kemudian saya lakukan restart manual menggunakan terminal di MikroTik dan normal kembali. Masalah kedua muncul di nordvpn MikroTik yang saya gunakan untuk koneksi game, terjadi bengong/tidak ada traffic tetapi masih terkoneksi, hal ini yang membuat saya menjadi jengkel akibat restart manual di terminal MikroTik. Saya cari tutorial dan menemukan scrip yang untuk reboot otomatis interface MikroTik.


Berikut adalah beberapa cara untuk menyelesaikan masalah di atas:

  1. Cabut dan pasang kembali kabel LAN kalian ke MikroTik, lalu uji ping hasilnya yang menunjukkan sukses atau tidak.

  2. Cara kedua lebih mudah dan sederhana, masuk ke MikroTik Router dan nonaktifkan-mengaktifkan interface ethernet yang bermasalah, Kemudian uji ping dan Hasil "Replay".

  3. Cara ke-3 lebih mudah, dengan menginstal skript pada Router MikroTik, sehingga jika Anda menguji ping maka hasil waktu habis router MikroTik akan secara otomatis menonaktifkan dan mengaktifkan ulang  interface atau dapat disebut istilah restart interface berulang kali dengan waktu yangtelah ditentukan sampai hasil menunjukkan " ping replay ".


Berikut adalah skrip yang dapat Anda gunakan untuk restart interface ethernet secara otomatis.

 

=============== start copying the script below this line====================

 

/system script
add name="Restart ether1"
source=":global runningRestartEther1r
n:if ([:len $runningRestartEther1] = 0 || $runningRestartEther1 = 0) do
={r
n /interface {r
n :set runningRestartEther1 1r
n :local o [find name="ether1"]r
n set $o disabled=yesr
n :delay 5r
n set $o disabled=nor
n :delay 2r
n :set runningRestartEther1 0r
n }r
n}r
n"

 

/system scheduler
add name="Restart ether1" on-event="Restart ether1"start-date=jan/01/1970 start-time=00:00:00 interval=2s

 

/tool netwatch
add host=1.1.1.1
down-script="/system scheduler set [find name="Restart ether1"] disabled=no"
up-script="/system scheduler set [find name="Restart ether1"] disabled=yes"

 

================ stop copy of the script above this line===================


Silakan Letakkan Skrip di bawah ini ke Terminal MikroTik Anda. silakan ganti variabel yang telah ditandai warna merah. dan jangan lupa untuk Menyesuaikan interface yang akan Anda restart secara otomatis. misalnya "ether1".


Skrip ini diambil dari = Forum MikroTik

Ganti nama interface "ether1" sesuai dengan ethernet atau interface yang bermasalah di Router MikroTik Anda.

Ganti host = 1.1.1.1 sesuai dengan IP tujuan yang akan Anda pantau (Dalam hal ini silakan gunakan server atau ip yang jarang offline karena biasnaya jika menggunakan ip yang sering offline MikroTik router akan berpikir interface ini error).


Semoga bermanfaat, jangan lupa bookmark web ini ya. dan membantu mendukung agar web ini terus memberikan afirmasi tentang teknologi yang menarik. Terimakasih telah mengunjungi Reboot Otomatis Interface MikroTik .

Begitu banyak, mungkin itu berguna

Posting Komentar untuk "Reboot Otomatis Interface MikroTik "