Skip to content Skip to sidebar Skip to footer

Bandwidth Priority Video Conference Zoom


Article

Bandwidth Priority Video Conference Zoom

zoom ip ip zoom international ip  zoom on mikrotik  priority zoom Mikrotik Router  Optimasi Zoom On MikroTik  Mikrotik Zoom IP Priority  Management Zoom Ip On Mikrotik


Meeting online via video conference is very important, as the world is currently adapting to the new normal of the Covid-19 pandemic. This is chosen because video conferences are considered a safe, convenient, and free way to stay connected, for business or social purposes.


There are various media used to conduct meetings or video conferences, one of which is widely used is Zoom Meeting. In this article we will try to optimize the network by prioritizing the connection that the video conference uses so that it can be used properly without any interruptions. The bandwidth used will be prioritized so as not to be disturbed when other clients are browsing to the internet.


Previously, we tried to first find all the information about the Zoom application, both from the ip server, protocols and ports used. Information from zoom's official website, zoom applications use TCP and UDP protocols with ports 80, 443, 3478, 3479, 5090, 5091, 8801-8810. Those protocols and ports that we will use to capture traffic to the Zoom server. In addition to protocols and ports, it can also be based on the IP of the Zoom server that we will add to the router.


Address Lists

For the first step, add the Zoom server IP List to the Router's Address-Lists Firewall. To make it easier, please check the list ip server zoom here : zoom-ip

Copy the zoom-ip script and insert it into the router by opening New Terminal and right-clicking Paste.


If successful, re-check the IP>Firewall>Address Lists" menu if IP Zoom is automatically added. There will be an IP list of Zoom servers with the name here : "zoom_ip".


zoom ip | ip zoom international ip | zoom on mikrotik | priority zoom Mikrotik Router | Optimasi Zoom On MikroTik | Mikrotik Zoom IP Priority | Management Zoom Ip On Mikrotik


Please note, not all IPs used by the Zoom server are in the script. To add automatically, add a mangle rule based on the port used by the zoom app.


Add two rules for TCP and UDP with destination ports namely ports 3478, 3479, 5090, 5091, 8801-8810 (in addition to 80 and 443).


Here's the command used:


/ip firewall mangle

add chain=prerouting dst-address-list=!zoom_ip dst-port=3478,3479,5090,5091,8801-8810 protocol=tcp action=add-dst-to-address-list address-list=zoom_ip;

add chain=prerouting dst-address-list=!zoom_ip dst-port=3478,3479,5090,5091,8801-8810 protocol=udp action=add-dst-to-address-list address-list=zoom_ip;

 

If using winbox the configuration is like the following :


zoom ip ip zoom international ip zoom on mikrotik priority zoom Mikrotik Router Optimasi Zoom On MikroTik Mikrotik Zoom IP Priority Management Zoom Ip On Mikrotik


Both of the above rules are used to add new IPs that are not yet listed in address-lists. The Address-Lists name is created the same as the import list "zoom_ip" and will update automatically if there is a new Zoom connection.


Mangle

Next step, to capture zoom app connection traffic, add a new rule to the mangle with the mark-connection action. Protocol ports populated ports used by zoom are PROTOCOL TCP and UDP with Ports 3478, 3479, 5090, 5091, 8801-8810. Name the captured connection, e.g. "koneksi_zoom".


Here's the command used.


/ip firewall mangle

add chain=prerouting protocol=tcp dst-port=3478,3479,5090,5091,8801-8810 action=mark-connection new-connection-mark=koneksi_zoom passthrough=yes;

add chain=prerouting protocol=udp dst-port=3478,3479,5090,5091,8801-8810 action=mark-connection new-connection-mark=koneksi_zoom passthrough=yes;


If using winbox the configuration is as follows:


zoom ip ip zoom international ip zoom on mikrotik priority zoom Mikrotik Router Optimasi Zoom On MikroTik Mikrotik Zoom IP Priority Management Zoom Ip On Mikrotik

In addition to ports 3478, 3479, 5090, 5091, 8801-8810, the Zoom application also uses tcp protocols 80 and TCP 443. Add a new rule with dst-port=80,443 and Dst. Address List = zoom_ip that you added earlier.


Here's the command used:


 /ip firewall mangle 
add chain=prerouting protocol=tcp dst-port=80,443 dst-address-list=zoom_ip action=mark-connection new-connection-mark=koneksi_zoom passthrough=yes


If using winbox the configuration is as follows:


zoom ip ip zoom international ip zoom on mikrotik priority zoom Mikrotik Router Optimasi Zoom On MikroTik Mikrotik Zoom IP Priority Management Zoom Ip On Mikrotik


The above rules are used to capture zoom traffic using tcp port protocol 80,443. There is additional dst-address-list=zoom-ip so that other browsing packages are not caught by this rule. Make sure the mark-connection name is the same as the previous rule (koneksi_zoom).


Once the connection is caught, there is one more rule to be added that is mark-packet. Add a new rule with action mark packet give it a new name, e.gpacket_zoom. Make sure the connection mark is filled in mark-connection = koneksi_zoom that has been created earlier. This packet-mark that we will use for bandwidth management, either in the simple queue menu or in the queue tree.


Here's the command used:


/ip firewall mangle

add chain=forward action=mark-packet connection-mark=koneksi_zoom new-packet-mark=paket_zoom passthrough=no

 


As a result there will be several rules on the mangle as follows




Bandwidth Management

Once the mark-packet is added to the mangle, try using the zoom app and look at the counters on the mangle to check if the rule is running correctly.


From packet-mark "paket_zoom" we can use to limit bandwidth on simple queue or queue tree. These packet-marks are used to distinguish which packets go to the zoom server, where packet browsing is common.


For example the configuration on simple queue is as follows:


zoom ip ip zoom international ip zoom on mikrotik priority zoom Mikrotik Router Optimasi Zoom On MikroTik Mikrotik Zoom IP Priority Management Zoom Ip On Mikrotik


While the configuration example on the queue tree, must add connection-mark and packet-mark browsing first.


zoom ip ip zoom international ip zoom on mikrotik priority zoom Mikrotik Router Optimasi Zoom On MikroTik Mikrotik Zoom IP Priority Management Zoom Ip On Mikrotik


We have just separated based on the packet-mark that has been created, the example is as follows:


zoom ip ip zoom international ip zoom on mikrotik priority zoom Mikrotik Router Optimasi Zoom On MikroTik Mikrotik Zoom IP Priority Management Zoom Ip On Mikrotik


This configuration can be a solution if you want to connect to a more priority zoom server without interruption. If there are other clients that are browsing, then it is separated bandwidth. In general, during a video conference, the zoom application will use the UDP protocol.  And the bandwidth used depends on the resolution used in the zoom meeting.


Indeed the information from zoom for the ports used on the TCP and UDP protocols is slightly different. The ports used on TCP and UDP are created equally for easy configuration.



Thanks.

Dani31
Dani31 2012 pertamakali Melakukan Blongging dani31 great web for support dani31 About Me About Me dani31